پشتیبانی « مشکلات عمومی « خطا بعد از انتقال سرور

  • حل شده ali abdi

    (@aliabdi7496)


    سلام من هاست رو انتقال دادم با خطای زیر مواجه میشم ، اول این خطا رو میداد بعد درست شد باز دوباره این خطا میده!

    Fatal error: Uncaught Error: Call to undefined function wp_scripts() in /home/arcaneteam/public_html/wp-includes/functions.wp-scripts.php:147 Stack trace: #0 /home/arcaneteam/public_html/wp-includes/widgets/class-wp-widget-text.php(59): wp_add_inline_script('text-widgets', 'wp.textWidgets....') #1 /home/arcaneteam/public_html/wp-includes/class-wp-widget.php(265): WP_Widget_Text->_register_one(1) #2 /home/arcaneteam/public_html/wp-includes/class-wp-widget-factory.php(102): WP_Widget->_register() #3 /home/arcaneteam/public_html/wp-includes/class-wp-hook.php(303): WP_Widget_Factory->_register_widgets('') #4 /home/arcaneteam/public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #5 /home/arcaneteam/public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array) #6 /home/arcaneteam/public_html/wp-includes/widgets.php(1809): do_action('widgets_init') #7 /home/arcaneteam/public_html/wp-includes/class-wp-hook.php(303): wp_widgets_init('') #8 /home/arcaneteam/public_html/wp-includes/class-wp-hook.ph in /home/arcaneteam/public_html/wp-includes/functions.wp-scripts.php on line 147

در حال نمایش 4 پاسخ ( از کل 4)
  • سلام
    کجا این خطا رو نشون میده؟ نسخه وردپرستون چنده؟ افزونه classic widgets نصبه؟

    Thread Starter ali abdi

    (@aliabdi7496)

    اخرین نسخه وردپرس فکر کنم 5.8 ، خیر نصب نیست – هم صفحه اصلی هم ادمین

    • این پاسخ 1 ماه، 4 هفته پیش توسط ali abdi اصلاح شده است.

    از قسمت ابزارها > تست سلامت سایت ببینید خطایی نداره
    // خطاها رو برطرف کنید
    اگر از گوتنبرگ استفاده نمی‌کنید classic widget رو هم نصب کنید در کنار classic editor
    // چک کنید خطا برقرار هست یا نه
    افزونه‌ها و پوسته رو به آخرین نسخه‌هاشون به روز کنید
    //مجدد چک کنید
    وارد کنترل پنل هاست بشید و فایل wp-config.php رو باز کنید ببنید اگر
    define(‘WP_DEBUG’, true);
    حالت دیباگ فعال هست اون رو به
    define(‘WP_DEBUG’, false);
    تغییر بدید (از اینجا کپی پیست نکنید کافیه true رو به false تغییر بدید)
    ممکنه قبل از انتقال از نسخه قدیمی‌تر وردپرس استفاده می‌کردید. در ورپرس 5.8 تغییرات قابل توجهی ایجاد شده که پوسته‌ها و افزونه‌ها زیادی تحت تاثیرش قرار گرفتن. برای اینکه بدونیم مشکل از پوسته است، پوسته پیش فرض رو فعال کنید ببینید خطا برقراره یا نه؟
    برای افزونه‌‌ها هم همینطور می‌تونید غیر فعالشون کنید و اگر مشکل حل شد یکی یکی فعال کنید تا برسید به افزونه مشکل ساز
    مرحله به مرحله پیش برید و درنهایت نتیجه رو اطلاع بدید

    Thread Starter ali abdi

    (@aliabdi7496)

    قالب رو به روزرسانی کردم حل شد! ممنون

در حال نمایش 4 پاسخ ( از کل 4)
  • The topic ‘خطا بعد از انتقال سرور’ is closed to new replies.